postgresql: update to version 9.0.1
[openwrt/svn-archive/archive.git] / libs / postgresql / patches / 200-ranlib.patch
index ef7d08a8fee503e366b81351fbffddae1c8cdf97..1b68b8378bdb706974c70122e992800b7f118b3e 100644 (file)
@@ -1,12 +1,10 @@
-Index: postgresql-8.2.5/src/port/Makefile
-===================================================================
---- postgresql-8.2.5.orig/src/port/Makefile    2007-09-20 10:18:17.000000000 -0500
-+++ postgresql-8.2.5/src/port/Makefile 2007-09-20 10:18:17.000000000 -0500
-@@ -43,6 +43,7 @@
+--- a/src/port/Makefile
++++ b/src/port/Makefile
+@@ -53,6 +53,7 @@ uninstall:
  
- libpgport.a: $(LIBOBJS)
+ libpgport.a: $(OBJS)
        $(AR) $(AROPT) $@ $^
 +      $(RANLIB) libpgport.a
  
+ # thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
  thread.o: thread.c
-       $(CC) $(CFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -c $<