[packages] libtorrent: apply fix from [22233] to armeb as well
[openwrt/svn-archive/archive.git] / libs / pwlib / Makefile
index aa02b3fdf5cbf6a842fd2a6c191a714242416ac7..36c4ae6ebb46403910c322f2335456c1491a8125 100644 (file)
@@ -1,35 +1,43 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwlib
-PKG_VERSION:=cvs-20051227
-PKG_RELEASE:=1
+PKG_VERSION:=1.11.1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://trash.uid0.hu/openwrt
-PKG_MD5SUM:=7d5b8e9ab61a05658a5630f91505420d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
+PKG_MD5SUM:=e1102dfd2608e3a117a2e016d0db53e3
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/pwlib-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pwlib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libpthread +uclibcxx
   TITLE:=Portable Windows library
-  URL:=http://www.openh323.org/
+  URL:=http://www.voxgratia.org/
+endef
+
+define Package/pwlib/description
+ PWLib is a moderately large class library that was created as a method to 
+ produce applications that run on both Microsoft Windows and the X Window 
+ System.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-minsize \
        --enable-openh323 \
-       --disable-opal \
+       --enable-opal \
        --disable-internalregex \
        --disable-plugins \
        --enable-audio \
@@ -42,7 +50,6 @@ CONFIGURE_ARGS += \
        --disable-ftp \
        --enable-http \
        --disable-httpsvc \
-       --disable-ipv6 \
        --disable-jabber \
        --disable-openldap \
        --disable-openssl \
@@ -59,7 +66,7 @@ CONFIGURE_ARGS += \
        --disable-snmp \
        --disable-soap \
        --disable-socks \
-       --disable-stun \
+       --enable-stun \
        --disable-telnet \
        --disable-tts \
        --disable-v4l \
@@ -68,19 +75,16 @@ CONFIGURE_ARGS += \
        --disable-video \
        --disable-vxml \
        --disable-wavfile \
-       --disable-xmlrpc
+       --disable-xmlrpc \
 
 CONFIGURE_VARS += \
-       CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti"
+       STDCXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
 
 MAKE_FLAGS += optnoshared
 
 define Build/InstallDev
        ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       $(SED) 's|//\(#include <ptlib/sound.h>\)|\1|' $(PKG_BUILD_DIR)/include/ptlib.h
 endef
 
 $(eval $(call BuildPackage,pwlib))