[packages] tcp_wrappers: Refresh patches
[openwrt/svn-archive/archive.git] / libs / radiusclient-ng / Makefile
index 487d6e36fd955650b622fac3b7bf4d7c74bbc16c..5a2a6ff8b7c4e17f53f33b51b06ae76b0e7f0285 100644 (file)
@@ -1,43 +1,44 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radiusclient-ng
-PKG_VERSION:=0.5.2
+PKG_VERSION:=0.5.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/radiusclient-ng/
-PKG_MD5SUM:=c54eb70e964bdd22dd44b39a9b4df8ca
+PKG_MD5SUM:=6fb7d4d0aefafaee7385831ac46a8e9c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/radiusclient-ng/Default
   URL:=http://developer.berlios.de/projects/radiusclient-ng/
 endef
-  
+
+define Package/radiusclient-ng/Default/description
+ Purpose of this project is to build a portable, easy-to-use and 
+ standard compliant library suitable for developing free and commercial 
+ software that need support for RADIUS protocol (RFCs 2128 and 2139).
+endef
+
 define Package/libradiusclient-ng
-  $(call Package/radiusclient-ng/Default)
+$(call Package/radiusclient-ng/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=RADIUS client library
 endef
 
 define Package/libradiusclient-ng/description
-=
-       Purpose of this project is to build a portable, easy-to-use and standard 
-       compliant library suitable for developing free and commercial software 
-       that need support for RADIUS protocol (RFCs 2128 and 2139).     
-       This package contains shared libraries, needed by other programs.
+$(call Package/radiusclient-ng/Default/description)
+ This package contains shared libraries, needed by other programs.
 endef
 
 define Package/libradiusclient-ng/conffiles
@@ -56,19 +57,15 @@ define Package/radiusclient-ng
 endef
 
 define Package/radiusclient-ng/description
-=
-       Purpose of this project is to build a portable, easy-to-use and standard 
-       compliant library suitable for developing free and commercial software 
-       that need support for RADIUS protocol (RFCs 2128 and 2139).     
-       This package contains a RADIUS client.
+$(call Package/radiusclient-ng/Default/description)
+ This package contains a RADIUS client.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -77,18 +74,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/radiusclient-ng.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libradiusclient-ng.{a,so}* $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/radiusclient-ng.h \
-               $(STAGING_DIR)/usr/lib/libradiusclient-ng.{a,so}*
-endef
-
 define Package/libradiusclient-ng/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/radiusclient-ng $(1)/etc/
@@ -98,7 +89,7 @@ endef
 
 define Package/radiusclient-ng/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rad{acct,iusclient,login,status} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rad{acct,iusclient,login,status} $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,libradiusclient-ng))