use Build/Configure/Default macro, Makefile cleanup
[openwrt/svn-archive/archive.git] / libs / readline / Makefile
index 1c336835fc0d1297d8c00e82e927393555e1c6c3..cf6e737fc82786e187a8e200049084b1845ad7be 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=readline
 PKG_VERSION:=5.1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/readline
 PKG_MD5SUM:=7ee5a692db88b30ca48927a13fd60e46
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -26,61 +26,30 @@ define Package/libreadline
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Command lines edition library
-  DESCRIPTION:=Command lines edition library\\\
-    The Readline library provides a set of functions for use by applications \\\
-    that allow users to edit command lines as they are typed in. Both Emacs \\\
-    and vi editing modes are available. The Readline library includes \\\
-    additional functions to maintain a list of previously-entered command \\\
-    lines, to recall and perhaps reedit those lines, and perform csh-like \\\
-    history expansion on previous commands.
+  DESCRIPTION:=\
+       The Readline library provides a set of functions for use by applications \\\
+       that allow users to edit command lines as they are typed in. Both Emacs \\\
+       and vi editing modes are available. The Readline library includes \\\
+       additional functions to maintain a list of previously-entered command \\\
+       lines, to recall and perhaps reedit those lines, and perform csh-like \\\
+       history expansion on previous commands.
   URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --without-curses \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --without-curses \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libreadline/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(STAGING_DIR)/usr/include/
@@ -94,4 +63,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/lib{history,readline}.{a,so*}
 endef
 
+define Package/libreadline/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libreadline))