[package] uclibc++: update to 0.2.3
[openwrt/svn-archive/archive.git] / libs / rrdtool-1.0.x / Makefile
index cb9c25f531ce94713ea357b31a50d5523fa2431c..22a1fe61113f96d93ffa93a7ed0285c9d87031ab 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rrdtool1
 PKG_VERSION:=1.0.50
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/rrdtool-$(PKG_VERSION)
 PKG_SOURCE:=rrdtool-$(PKG_VERSION).tar.gz
@@ -19,88 +19,72 @@ PKG_SOURCE_URL:= \
        ftp://ftp.sunet.se/pub/network/monitoring/rrdtool/rrdtool-1.0.x
 PKG_MD5SUM:=c466e2e7df95fa8e318e46437da87686
 
+PKG_FIXUP:=libtool
+
 include $(INCLUDE_DIR)/package.mk
 
+define Package/rrdtool1/Default
+  TITLE:=Round Robin Database (RRD)
+  URL:=http://oss.oetiker.ch/rrdtool/
+endef
+
+define Package/rrdtool1/description/Default
+ RRD is the Acronym for Round Robin Database. RRD is a system to store and
+ display time-series data (i.e. network bandwidth, machine-room temperature,
+ server load average). It stores the data in a very compact way that will
+ not expand over time, and it presents useful graphs by processing the data
+ to enforce a certain data density. It can be used either via simple wrapper
+ scripts (from shell or Perl) or via frontends that poll network devices and
+ put friendly user interface on it.
+
+ This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
+ librrd.so. The library is much smaller compared to the 1.2.x version with
+ separate dynamic linked libraries.
+endef
+
 define Package/librrd1
+$(call Package/rrdtool1/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+zlib
-  TITLE:=Round Robin Database (RRD) management library
-  URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+  TITLE+= management library
 endef
 
 define Package/librrd1/description
-Round Robin Database (RRD) management library.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and
-       display time-series data (i.e. network bandwidth, machine-room temperature,
-       server load average). It stores the data in a very compact way that will
-       not expand over time, and it presents useful graphs by processing the data
-       to enforce a certain data density. It can be used either via simple wrapper
-       scripts (from shell or Perl) or via frontends that poll network devices and
-       put friendly user interface on it.
-
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
-       librrd.so. The library is much smaller compared to the 1.2.x version with
-       separate dynamic linked libraries.
-
-       This package contains a shared library, used by other programs.
+$(call Package/rrdtool1/description/Default)
+ This package contains a shared library, used by other programs.
 endef
 
 define Package/rrdcgi1
+$(call Package/rrdtool1/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+librrd1
-  TITLE:=Round Robin Database (RRD) CGI graphing tool
-  URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+  TITLE+= CGI graphing tool
 endef
 
 define Package/rrdcgi1/description
-Round Robin Database (RRD) CGI graphing tool.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and
-       display time-series data (i.e. network bandwidth, machine-room temperature,
-       server load average). It stores the data in a very compact way that will
-       not expand over time, and it presents useful graphs by processing the data
-       to enforce a certain data density. It can be used either via simple wrapper
-       scripts (from shell or Perl) or via frontends that poll network devices and
-       put friendly user interface on it.
-
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
-       librrd.so. The library is much smaller compared to the 1.2.x version with
-       separate dynamic linked libraries.
-
-       This package contains the rrdcgi tool used to create web pages containing
-       RRD graphs based on templates.
+$(call Package/rrdtool1/description/Default)
+ This package contains the rrdcgi tool used to create web pages containing
+ RRD graphs based on templates.
 endef
 
 define Package/rrdtool1
+$(call Package/rrdtool1/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+librrd1
-  TITLE:=Round Robin Database (RRD) management tools
-  URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+  TITLE+= management tools
 endef
 
 define Package/rrdtool1/description
-Round Robin Database (RRD) management tools.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and
-       display time-series data (i.e. network bandwidth, machine-room temperature,
-       server load average). It stores the data in a very compact way that will
-       not expand over time, and it presents useful graphs by processing the data
-       to enforce a certain data density. It can be used either via simple wrapper
-       scripts (from shell or Perl) or via frontends that poll network devices and
-       put friendly user interface on it.
-
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
-       librrd.so. The library is much smaller compared to the 1.2.x version with
-       separate dynamic linked libraries.
-
-       This package contains command line tools used to manage RRDs.
+$(call Package/rrdtool1/description/Default)
+ This package contains command line tools used to manage RRDs.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) --std=c99
 
 CONFIGURE_ARGS += \
-       $(DISABLE_LARGEFILE) \
        $(DISABLE_NLS) \
        --enable-shared=yes \
        --enable-static=yes \
@@ -114,8 +98,6 @@ CONFIGURE_VARS += \
        shrext_cmds=".so"
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                shrext_cmds=".so" \
@@ -124,12 +106,12 @@ endef
 
 define Package/rrdtool1/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rrd{tool,update} $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrd{tool,update} $(1)/usr/bin/
 endef
 
 define Package/rrdcgi1/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(1)/usr/bin/
 endef
 
 define Package/librrd1/install
@@ -138,10 +120,10 @@ define Package/librrd1/install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/rrd.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/rrdtool-1.0/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/rrd.h $(1)/usr/lib/rrdtool-1.0/include/
+       $(INSTALL_DIR)  $(1)/usr/lib/rrdtool-1.0/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.{a,so*} $(1)/usr/lib/rrdtool-1.0/lib/
 endef
 
 $(eval $(call BuildPackage,librrd1))