[packages] net-snmp: Add option 'execname' to allow the usage of same exec names
[openwrt/svn-archive/archive.git] / libs / rrdtool-1.0.x / Makefile
index bc79f154503754d73203222b79eff253b222ec59..af19bd5bcf60f8b6a3887528084d72240e29ea89 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -98,42 +97,21 @@ Round Robin Database (RRD) management tools.
        This package contains command line tools used to manage RRDs.
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{status,cache} ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_path_PERL=no \
-               rd_cv_ieee_works=yes \
-               shrext_cmds=".so" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared=yes \
-                       --enable-static=yes \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --enable-local-zlib \
-       );
-endef
+TARGET_CFLAGS += $(FPIC) --std=c99
+
+CONFIGURE_ARGS += \
+       $(DISABLE_LARGEFILE) \
+       $(DISABLE_NLS) \
+       --enable-shared=yes \
+       --enable-static=yes \
+       --disable-rpath \
+       --with-gnu-ld \
+       --enable-local-zlib
+
+CONFIGURE_VARS += \
+       ac_cv_path_PERL=no \
+       rd_cv_ieee_works=yes \
+       shrext_cmds=".so"
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)