[packages] c-ares: update to 1.7.1
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index b8a5f431467788653db346b1a4f8b5a28626b779..24ce114d5616c190a3f1a098f9d05dd16b2d8062 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
 PKG_VERSION:=1.2beta3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
 PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -59,8 +59,6 @@ define Package/libspeexdsp/description
        This package contains the shared dsp library, needed by other programs.
 endef
 
-TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -68,8 +66,8 @@ define Build/Configure
                --enable-fixed-point \
                --disable-oggtest \
                --disable-float-api \
-               --disable-vbr, \
-               OGG_CFLAGS="" \
+               --disable-vbr \
+               --with-ogg=$(STAGING_DIR)/usr \
        )
 endef