[packages] c-ares: update to 1.7.1
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index bd64f38e3cf1f7175ab7ec94b159355d52b8a7ae..24ce114d5616c190a3f1a098f9d05dd16b2d8062 100644 (file)
@@ -1,22 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
 PKG_VERSION:=1.2beta3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
 PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,6 +26,13 @@ define Package/libspeex
   URL:=http://www.speex.org/
 endef
 
+define Package/libspeexdsp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Open source speech compression codec library output to DSP
+  URL:=http://www.speex.org/
+endef
+
 define Package/libspeex/description
        Open source patent-free speech compression codec library.
        Speex is an Open Source/Free Software patent-free audio compression 
@@ -39,7 +45,19 @@ define Package/libspeex/description
        This package contains the shared codec library, needed by other programs.
 endef
 
-TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
+TARGET_CFLAGS += $(FPIC)
+
+define Package/libspeexdsp/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared dsp library, needed by other programs.
+endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -48,8 +66,8 @@ define Build/Configure
                --enable-fixed-point \
                --disable-oggtest \
                --disable-float-api \
-               --disable-vbr, \
-               OGG_CFLAGS="" \
+               --disable-vbr \
+               --with-ogg=$(STAGING_DIR)/usr \
        )
 endef
 
@@ -61,12 +79,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speexdsp.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libspeex/install
@@ -74,4 +94,11 @@ define Package/libspeex/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.so.* $(1)/usr/lib/
 endef
 
+define Package/libspeexdsp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libspeex))
+$(eval $(call BuildPackage,libspeexdsp))
+