enable $(FPIC) for a few more packages
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index 733251c18424976de4d99ee1bfca54c87da24d8a..3985865fc185ccf907c8ed81d72d14e3e3310b91 100644 (file)
@@ -9,15 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2beta1
+PKG_VERSION:=1.2beta3.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=aac2e4ba42122b885c787ea280acb3d9
+PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
@@ -37,10 +35,12 @@ define Package/libspeex/description
        alternative to expensive proprietary speech codecs. Moreover, Speex 
        is well-adapted to Internet applications and provides useful features 
        that are not present in most other codecs.
-       
+
        This package contains the shared codec library, needed by other programs.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
 
 define Build/Configure
@@ -49,6 +49,9 @@ define Build/Configure
                --enable-static \
                --enable-fixed-point \
                --disable-oggtest \
+               --disable-float-api \
+               --disable-vbr, \
+               OGG_CFLAGS="" \
        )
 endef