usb-modeswitch: Fix a condition to compare default product id and switched product...
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index 1250dd55530c552885977c62633a6da361cf4f5f..57fa983c2c5028262c138ad7c6f3384d68b70259 100644 (file)
@@ -1,22 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2beta3.2
+PKG_VERSION:=1.2rc1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
+PKG_MD5SUM:=c4438b22c08e5811ff10e2b06ee9b9ae
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -60,8 +59,6 @@ define Package/libspeexdsp/description
        This package contains the shared dsp library, needed by other programs.
 endef
 
-TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -69,8 +66,8 @@ define Build/Configure
                --enable-fixed-point \
                --disable-oggtest \
                --disable-float-api \
-               --disable-vbr, \
-               OGG_CFLAGS="" \
+               --disable-vbr \
+               --with-ogg=$(STAGING_DIR)/usr \
        )
 endef