[packages] speex: update to 1.2rc1
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index ddbc00fd49cd793a22c15a28293ed2d03ea67fb0..57fa983c2c5028262c138ad7c6f3384d68b70259 100644 (file)
@@ -1,25 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2beta1
+PKG_VERSION:=1.2rc1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=aac2e4ba42122b885c787ea280acb3d9
-PKG_CAT:=zcat
+PKG_MD5SUM:=c4438b22c08e5811ff10e2b06ee9b9ae
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,20 +23,41 @@ define Package/libspeex
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Open source speech compression codec library
-  DESCRIPTION:=\
-       Open source patent-free speech compression codec library.\\\
-       Speex is an Open Source/Free Software patent-free audio compression \\\
-       format designed for speech. The Speex Project aims to lower the \\\
-       barrier of entry for voice applications by providing a free \\\
-       alternative to expensive proprietary speech codecs. Moreover, Speex \\\
-       is well-adapted to Internet applications and provides useful features \\\
-       that are not present in most other codecs.\\\
-       \\\
-       This package contains the shared codec library, needed by other programs.
   URL:=http://www.speex.org/
 endef
 
-TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
+define Package/libspeexdsp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Open source speech compression codec library output to DSP
+  URL:=http://www.speex.org/
+endef
+
+define Package/libspeex/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared codec library, needed by other programs.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Package/libspeexdsp/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared dsp library, needed by other programs.
+endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -48,6 +65,9 @@ define Build/Configure
                --enable-static \
                --enable-fixed-point \
                --disable-oggtest \
+               --disable-float-api \
+               --disable-vbr \
+               --with-ogg=$(STAGING_DIR)/usr \
        )
 endef
 
@@ -59,21 +79,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/speex \
-               $(STAGING_DIR)/usr/lib/libspeex.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speexdsp.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libspeex/install
@@ -81,4 +94,11 @@ define Package/libspeex/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.so.* $(1)/usr/lib/
 endef
 
+define Package/libspeexdsp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libspeex))
+$(eval $(call BuildPackage,libspeexdsp))
+