packages: Update libspeex to 1.2beta3
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index 81db45b9cb8b798b96f4e25466bfb0947153cda2..d7b0a22379f544f789caaa99c7ba7ff5276e21a8 100644 (file)
@@ -9,16 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.1.12
+PKG_VERSION:=1.2beta3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=1bd6cdf3a0ebabf818cd72a3401e2610
-PKG_CAT:=zcat
+PKG_MD5SUM:=bcada04dc663a725ee7fcfa6301520a3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,19 +26,21 @@ define Package/libspeex
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Open source speech compression codec library
-  DESCRIPTION:=\
-       Open source patent-free speech compression codec library.\\\
-       Speex is an Open Source/Free Software patent-free audio compression \\\
-       format designed for speech. The Speex Project aims to lower the \\\
-       barrier of entry for voice applications by providing a free \\\
-       alternative to expensive proprietary speech codecs. Moreover, Speex \\\
-       is well-adapted to Internet applications and provides useful features \\\
-       that are not present in most other codecs.\\\
-       \\\
-       This package contains the shared codec library, needed by other programs.
   URL:=http://www.speex.org/
 endef
 
+define Package/libspeex/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared codec library, needed by other programs.
+endef
+
 TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
 
 define Build/Configure
@@ -47,6 +49,8 @@ define Build/Configure
                --enable-static \
                --enable-fixed-point \
                --disable-oggtest \
+               --disable-float-api \
+               --disable-vbr \
        )
 endef
 
@@ -58,21 +62,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/speex \
-               $(STAGING_DIR)/usr/lib/libspeex.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libspeex/install