remove UninstallDev
[openwrt/svn-archive/archive.git] / libs / sqlite2 / Makefile
index edd3edd338b02a6b86e6ea081debdfef3810d435..877c3a3c7e666760497b12f463d2cffb2499f88f 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=sqlite-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
 PKG_MD5SUM:=838dbac20b56d2c4292e98848505a05b
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/sqlite-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,9 +25,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite2/Default
   TITLE:=SQLite (v2.x) database engine
-  DESCRIPTION:=\
-       SQLite is a small C library that implements a self-contained, embeddable, \\\
-       zero-configuration SQL database engine.
   URL:=http://www.sqlite.org/
 endef
 
@@ -37,8 +33,12 @@ define Package/libsqlite2
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       \\\
+endef
+
+define Package/libsqlite2/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
        This package contains the SQLite (v2.x) shared library, used by other programs.
 endef
 
@@ -48,10 +48,15 @@ define Package/sqlite2-cli
   CATEGORY:=Utilities
   DEPENDS:=+libsqlite2 +libncurses +libreadline
   TITLE+= (cli)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains a terminal-based front-end to the SQLite (v2.x) library \\\
-       that can evaluate queries interactively and display the results in \\\
+  SUBMENU:=database
+endef
+
+define Package/sqlite2-cli/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
+       This package contains a terminal-based front-end to the SQLite (v2.x) library 
+       that can evaluate queries interactively and display the results in 
        multiple formats.
 endef
 
@@ -77,18 +82,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sqlite.h \
-               $(STAGING_DIR)/usr/lib/libsqlite.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/sqlite.pc
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libsqlite2/install
@@ -98,7 +97,7 @@ endef
 
 define Package/sqlite2-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sqlite $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sqlite $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libsqlite2))