more package submenus
[openwrt/svn-archive/archive.git] / libs / sqlite2 / Makefile
index 189791c7f740d8fac21582cc542a494917dfe8fc..aa8bae9568912188d34d372f906074d510bc71da 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=sqlite-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
 PKG_MD5SUM:=838dbac20b56d2c4292e98848505a05b
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/sqlite-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,9 +25,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite2/Default
   TITLE:=SQLite (v2.x) database engine
-  DESCRIPTION:=\
-       SQLite is a small C library that implements a self-contained, embeddable, \\\
-       zero-configuration SQL database engine.
   URL:=http://www.sqlite.org/
 endef
 
@@ -37,8 +33,12 @@ define Package/libsqlite2
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       \\\
+endef
+
+define Package/libsqlite2/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
        This package contains the SQLite (v2.x) shared library, used by other programs.
 endef
 
@@ -48,10 +48,15 @@ define Package/sqlite2-cli
   CATEGORY:=Utilities
   DEPENDS:=+libsqlite2 +libncurses +libreadline
   TITLE+= (cli)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains a terminal-based front-end to the SQLite (v2.x) library \\\
-       that can evaluate queries interactively and display the results in \\\
+  SUBMENU:=database
+endef
+
+define Package/sqlite2-cli/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
+       This package contains a terminal-based front-end to the SQLite (v2.x) library 
+       that can evaluate queries interactively and display the results in 
        multiple formats.
 endef