Package libgslblas as well and fix shared object symlinks
[openwrt/svn-archive/archive.git] / libs / sqlite3 / Makefile
index 7f97f7203690288eef55a7a841e8e0b26397ea81..71157a2e269f1e2e99768ccc241debc4efacbe6a 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
 PKG_MD5SUM:=2feec9b429f9298c9f288420c8b449f8
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,10 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite3/Default
   TITLE:=SQLite (v3.x) database engine
-  DESCRIPTION:=\
-       SQLite is a small C library that implements a self-contained, embeddable, \\\
-       zero-configuration SQL database engine.
   URL:=http://www.sqlite.org/
+  SUBMENU:=database
 endef
 
 define Package/libsqlite3
@@ -37,8 +34,12 @@ define Package/libsqlite3
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       This package contains the SQLite (v3.x) shared library, used by other programs.
+endef
+
+define Package/libsqlite3/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. This package contains the SQLite (v3.x) shared library, used by other programs.
 endef
 
 define Package/sqlite3-cli
@@ -47,10 +48,14 @@ define Package/sqlite3-cli
   CATEGORY:=Utilities
   DEPENDS:=+libsqlite3 +libncurses +libreadline
   TITLE+= (cli)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains a terminal-based front-end to the SQLite (v3.x) library \\\
-       that can evaluate queries interactively and display the results in \\\
+endef
+
+define Package/sqlite3-cli/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
+       This package contains a terminal-based front-end to the SQLite (v3.x) library 
+       that can evaluate queries interactively and display the results in 
        multiple formats.
 endef
 
@@ -84,12 +89,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sqlite3.h \
-               $(STAGING_DIR)/usr/lib/libsqlite3.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
-endef
-
 define Package/libsqlite3/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.so.* $(1)/usr/lib/
@@ -97,7 +96,7 @@ endef
 
 define Package/sqlite3-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libsqlite3))