This patch contains a package with two PPS-tools and a header file,
[openwrt/svn-archive/archive.git] / libs / sqlite3 / Makefile
index 9e39b47d21ac0012bcf193e849f12a9c0988368d..71157a2e269f1e2e99768ccc241debc4efacbe6a 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite
-PKG_VERSION:=3.3.3
+PKG_VERSION:=3.4.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
-PKG_MD5SUM:=eb5d9d7e7853b3af78e767d709b7fced
-PKG_CAT:=zcat
+PKG_MD5SUM:=2feec9b429f9298c9f288420c8b449f8
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,10 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite3/Default
   TITLE:=SQLite (v3.x) database engine
-  DESCRIPTION:=\
-       SQLite is a small C library that implements a self-contained, embeddable, \\\
-       zero-configuration SQL database engine.
   URL:=http://www.sqlite.org/
+  SUBMENU:=database
 endef
 
 define Package/libsqlite3
@@ -37,8 +34,12 @@ define Package/libsqlite3
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       This package contains the SQLite (v3.x) shared library, used by other programs.
+endef
+
+define Package/libsqlite3/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. This package contains the SQLite (v3.x) shared library, used by other programs.
 endef
 
 define Package/sqlite3-cli
@@ -47,10 +48,14 @@ define Package/sqlite3-cli
   CATEGORY:=Utilities
   DEPENDS:=+libsqlite3 +libncurses +libreadline
   TITLE+= (cli)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains a terminal-based front-end to the SQLite (v3.x) library \\\
-       that can evaluate queries interactively and display the results in \\\
+endef
+
+define Package/sqlite3-cli/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
+       This package contains a terminal-based front-end to the SQLite (v3.x) library 
+       that can evaluate queries interactively and display the results in 
        multiple formats.
 endef
 
@@ -76,20 +81,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sqlite3.h \
-               $(STAGING_DIR)/usr/lib/libsqlite3.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libsqlite3/install
@@ -99,7 +96,7 @@ endef
 
 define Package/sqlite3-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libsqlite3))