more package submenus
[openwrt/svn-archive/archive.git] / libs / sqlite3 / Makefile
index 0d2cee9e16d98789518ab54a44a95acee9a8620a..a39f73623fb90692d4089f7673b7ca22694a90f9 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
 PKG_MD5SUM:=2feec9b429f9298c9f288420c8b449f8
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,10 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite3/Default
   TITLE:=SQLite (v3.x) database engine
-  DESCRIPTION:=\
-       SQLite is a small C library that implements a self-contained, embeddable, \\\
-       zero-configuration SQL database engine.
   URL:=http://www.sqlite.org/
+  SUBMENU:=database
 endef
 
 define Package/libsqlite3
@@ -37,8 +34,12 @@ define Package/libsqlite3
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DESCRIPTION+=\\\
-       This package contains the SQLite (v3.x) shared library, used by other programs.
+endef
+
+define Package/libsqlite3/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. This package contains the SQLite (v3.x) shared library, used by other programs.
 endef
 
 define Package/sqlite3-cli
@@ -47,10 +48,14 @@ define Package/sqlite3-cli
   CATEGORY:=Utilities
   DEPENDS:=+libsqlite3 +libncurses +libreadline
   TITLE+= (cli)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains a terminal-based front-end to the SQLite (v3.x) library \\\
-       that can evaluate queries interactively and display the results in \\\
+endef
+
+define Package/sqlite3-cli/description
+=
+       SQLite is a small C library that implements a self-contained, embeddable, 
+       zero-configuration SQL database engine. 
+       This package contains a terminal-based front-end to the SQLite (v3.x) library 
+       that can evaluate queries interactively and display the results in 
        multiple formats.
 endef
 
@@ -76,12 +81,12 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Build/UninstallDev