[packages] sqlite3: update to v3.6.18
[openwrt/svn-archive/archive.git] / libs / sqlite3 / Makefile
index 36ecd83c2cc3bb358d7f415077ad005bb963e53b..b100ff5c20acc34503d50d3481ab2268f6686c26 100644 (file)
@@ -1,42 +1,47 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite
-PKG_VERSION:=3.4.2
+PKG_VERSION:=3.6.18
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-amalgamation-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
-PKG_MD5SUM:=2feec9b429f9298c9f288420c8b449f8
+PKG_MD5SUM:=18c9f044e2f50cdab3bca87386d4fcc8
 
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite3/Default
+  SUBMENU:=database
   TITLE:=SQLite (v3.x) database engine
   URL:=http://www.sqlite.org/
-  SUBMENU:=database
+endef
+
+define Package/sqlite3/Default/description
+ SQLite is a small C library that implements a self-contained, embeddable,
+ zero-configuration SQL database engine.
 endef
 
 define Package/libsqlite3
   $(call Package/sqlite3/Default)
   SECTION:=libs
   CATEGORY:=Libraries
+  DEPENDS:=+libpthread
   TITLE+= (library)
 endef
 
 define Package/libsqlite3/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
      zero-configuration SQL database engine. This package contains the SQLite (v3.x) shared library, used by other programs.
+$(call Package/sqlite3/Default/description)
+ This package contains the SQLite (v3.x) shared library, used by other
+ programs.
 endef
 
 define Package/sqlite3-cli
@@ -48,30 +53,25 @@ define Package/sqlite3-cli
 endef
 
 define Package/sqlite3-cli/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
-       zero-configuration SQL database engine. 
-       This package contains a terminal-based front-end to the SQLite (v3.x) library 
-       that can evaluate queries interactively and display the results in 
-       multiple formats.
+$(call Package/sqlite3/Default/description)
+ This package contains a terminal-based front-end to the SQLite (v3.x) library
+ that can evaluate queries interactively and display the results in multiple
+ formats.
 endef
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-tcl \
-               , \
-               config_BUILD_CC="$(HOSTCC)" \
-               config_BUILD_CFLAGS="-O2" \
-               config_TARGET_CC="$(TARGET_CC)" \
-               config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-               config_TARGET_READLINE_INC="-I$(STAGING_DIR)/usr/include" \
-               config_TARGET_READLINE_LIBS="-L$(STAGING_DIR)/usr/lib -lreadline -lncurses" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+CONFIGURE_VARS += \
+       config_BUILD_CC="$(HOSTCC)" \
+       config_BUILD_CFLAGS="-O2" \
+       config_TARGET_CC="$(TARGET_CC)" \
+       config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+       config_TARGET_READLINE_INC="$(TARGET_CPPFLAGS)" \
+       config_TARGET_READLINE_LIBS="$(TARGET_LDFLAGS) -lreadline -lncurses" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -80,11 +80,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(1)/usr/lib/pkgconfig/
 endef