[package] update sqlite3 to 3.6.14, switch to amalgation tarball (#5131)
[openwrt/svn-archive/archive.git] / libs / sqlite3 / Makefile
index 1aaec13fe9a9647960c9e2d5ee837fedc192bdc7..d4f02393dc538229ab989dba6ffccf5c99fd9465 100644 (file)
@@ -1,44 +1,47 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite
-PKG_VERSION:=3.4.2
+PKG_VERSION:=3.6.14
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-amalgamation-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org/
-PKG_MD5SUM:=2feec9b429f9298c9f288420c8b449f8
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=cfe9d3021cfdb58e2b02a36a4cb6b70c
 
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite3/Default
+  SUBMENU:=database
   TITLE:=SQLite (v3.x) database engine
   URL:=http://www.sqlite.org/
 endef
 
+define Package/sqlite3/Default/description
+ SQLite is a small C library that implements a self-contained, embeddable,
+ zero-configuration SQL database engine.
+endef
+
 define Package/libsqlite3
   $(call Package/sqlite3/Default)
   SECTION:=libs
   CATEGORY:=Libraries
+  DEPENDS:=+libpthread
   TITLE+= (library)
 endef
 
 define Package/libsqlite3/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
      zero-configuration SQL database engine. This package contains the SQLite (v3.x) shared library, used by other programs.
+$(call Package/sqlite3/Default/description)
+ This package contains the SQLite (v3.x) shared library, used by other
+ programs.
 endef
 
 define Package/sqlite3-cli
@@ -50,28 +53,25 @@ define Package/sqlite3-cli
 endef
 
 define Package/sqlite3-cli/description
-=
-       SQLite is a small C library that implements a self-contained, embeddable, 
-       zero-configuration SQL database engine. 
-       This package contains a terminal-based front-end to the SQLite (v3.x) library 
-       that can evaluate queries interactively and display the results in 
-       multiple formats.
+$(call Package/sqlite3/Default/description)
+ This package contains a terminal-based front-end to the SQLite (v3.x) library
+ that can evaluate queries interactively and display the results in multiple
+ formats.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-tcl \
-               , \
-               config_BUILD_CC="$(HOSTCC)" \
-               config_BUILD_CFLAGS="-O2" \
-               config_TARGET_CC="$(TARGET_CC)" \
-               config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-               config_TARGET_READLINE_INC="-I$(STAGING_DIR)/usr/include" \
-               config_TARGET_READLINE_LIBS="-L$(STAGING_DIR)/usr/lib -lreadline -lncurses" \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+CONFIGURE_VARS += \
+       config_BUILD_CC="$(HOSTCC)" \
+       config_BUILD_CFLAGS="-O2" \
+       config_TARGET_CC="$(TARGET_CC)" \
+       config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+       config_TARGET_READLINE_INC="$(TARGET_CPPFLAGS)" \
+       config_TARGET_READLINE_LIBS="$(TARGET_LDFLAGS) -lreadline -lncurses" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -80,20 +80,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite3.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/sqlite3.h \
-               $(STAGING_DIR)/usr/lib/libsqlite3.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
-endef
-
 define Package/libsqlite3/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.so.* $(1)/usr/lib/
@@ -101,7 +95,7 @@ endef
 
 define Package/sqlite3-cli/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sqlite3 $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libsqlite3))