[package] uploaded new st2205tool tarball with fixed permissions
[openwrt/svn-archive/archive.git] / libs / st2205tool / Makefile
index 2e5e7b5304495f6ad3eaefa544576391857cd876..29ac98c3d13da6fbea4e667ff8e5ad5d9148f2ef 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=st2205tool
-PKG_VERSION:=1.4pre1
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.3
+PKG_RELEASE:=2
 
-PKG_SOURCE:=st2205tool-v$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://spritesmods.com/picframe/
-PKG_MD5SUM:=bf602227bce9c4365e5ae5e9b383d8d9
+PKG_SOURCE:=st2205tool-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=827e3b719ebaf6bc537f2ce0ece3fccb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -50,10 +50,9 @@ endef
 
 define Package/st2205tool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{bgrep,phack,splice,hackfw.sh} $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/setpic/setpic $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libst2205/libst2205.so* $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/libst2205/libst2205.so $(1)/usr/lib/libst2205.so.1
 endef
 
 $(eval $(call BuildPackage,st2205tool))