Add libptmalloc3 from #2667
[openwrt/svn-archive/archive.git] / libs / taglib / Makefile
index eeb70b4fa8e93c8a5509bfe8cc4767993b317e5e..d940166b5a3e7a152b2ae1b97942a1d29b030e06 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,17 +15,22 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://developer.kde.org/~wheeler/files/src/
 PKG_MD5SUM:=dcd50ddb2544faeae77f194804559404
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/taglib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:= +uclibcxx +zlib
+  DEPENDS:= +uclibcxx +zlib @!TARGET_avr32
   TITLE:=Audio output library
   URL:=http://developer.kde.org/~wheeler/taglib.html
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -37,25 +42,23 @@ CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS" \
        LIBS="-nodefaultlibs -lz -luClibc++" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/taglib-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/include/taglib
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/taglib/* $(1)/usr/include/taglib/
-endef
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/taglib-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/taglib-config
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/taglib-config \
-               $(STAGING_DIR)/usr/include/taglib \
-               $(STAGING_DIR)/usr/lib/libtag.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libtag.{la,so*} \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include/taglib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/taglib/* \
+               $(1)/usr/include/taglib/
 endef
 
 define Package/taglib/install