[packages] Move libtiff c++ bindings into it's own package
[openwrt/svn-archive/archive.git] / libs / tiff / Makefile
index 398961b40109930e39b5eb5a7440d91f586607ce..3bef8632859ebff82092264c11146a46c8f2d531 100644 (file)
@@ -9,29 +9,77 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tiff
-PKG_VERSION:=3.8.2
-PKG_RELEASE:=2
+PKG_VERSION:=3.9.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://libtiff.maptools.org/dl/
-PKG_MD5SUM:=fbb6f446ea4ed18955e2714934e5b698
-PKG_FIXUP:=libtool
+PKG_SOURCE_URL:=http://download.osgeo.org/libtiff
+PKG_MD5SUM:=93e56e421679c591de7552db13384cb8
+
+PKG_FIXUP:=libtool-uclibcxx
+PKG_INSTALL:=1
+
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_libtiffxx
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
+define Package/tiff/Default
+  TITLE:=TIFF
+  URL:=http://www.remotesensing.org/libtiff/
+endef
 
 define Package/libtiff
+$(call Package/tiff/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=TIFF libraries
+  TITLE+= library
   DEPENDS:=+zlib +libjpeg
-  URL:=http://www.remotesensing.org/libtiff/
+endef
+
+define Package/libtiffxx
+$(call Package/tiff/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= library(c++ bindings)
+  DEPENDS:=+libtiff +uclibcxx
+endef
+
+define Package/tiff-utils
+$(call Package/tiff/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= utilities
+  DEPENDS:=+libtiff
 endef
 
 TARGET_CFLAGS += $(FPIC)
 
-CONFIGURE_ARGS += --without-x
+MAKE_FLAGS += \
+    CXX="g++-uc"
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               $(if $(CONFIG_PACKAGE_libtiffxx), \
+                       --enable-cxx, \
+                       --disable-cxx \
+               ) \
+               --enable-ccitt \
+               --enable-packbits \
+               --enable-lzw \
+               --enable-thunder \
+               --enable-next \
+               --enable-logluv \
+               --enable-mdi \
+               --enable-zlib \
+               --enable-jpeg \
+               --disable-old-jpeg \
+               --disable-jbig \
+               --without-x \
+               --with-apple-opengl-framework \
+               , \
+               CXX="g++-uc" \
+       )
+endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include}
@@ -41,7 +89,19 @@ endef
 
 define Package/libtiff/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so.* $(1)/usr/lib/
+endef
+
+define Package/libtiffxx/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so.* $(1)/usr/lib/
+endef
+
+define Package/tiff-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libtiff))
+$(eval $(call BuildPackage,libtiffxx))
+$(eval $(call BuildPackage,tiff-utils))