ustl does not work on avr32
[openwrt/svn-archive/archive.git] / libs / ustl / Makefile
index c9b9d5ed741df2992187a42055808b3ff7d0db0f..69ed7f9ac1c7ddb326341d57e89cb3a9951ea066 100644 (file)
@@ -16,9 +16,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-0.8-0.tar.bz2
 PKG_SOURCE_URL:=@SF/ustl
 PKG_MD5SUM:=dd59483c327f1bd1356273bc5ae4dde0
-PKG_CAT:=bzcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,12 +23,16 @@ define Package/ustl
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C++ STL for embedded systems
-  DESCRIPTION:=C++ Standard Template Library (STL) for embedded systems.\\\
+  DEPENDS:=@!TARGET_avr32
+  URL:=http://ustl.sourceforge.net/
+endef
+
+define Package/ustl/description
+       C++ Standard Template Library (STL) for embedded systems.\\\
     uSTL is a partial implementation of the STL (Standard Template \\\
     Library) that reduces code size by factoring memory management \\\
     code into a non-template base class and deriving containers \\\
     from it.
-  URL:=http://ustl.sourceforge.net/
 endef
 
 define Build/Configure
@@ -61,10 +62,4 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libustl.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/ustl* \
-               $(STAGING_DIR)/usr/lib/libustl.{a,so*}
-endef
-
 $(eval $(call BuildPackage,ustl))