Add libtool fixup to taglib.
[openwrt/svn-archive/archive.git] / libs / ustl / Makefile
index 07731f1292dce1673cec0bc2916c4ecfe23f3122..e98a9a3709430ee938cc1cb1320673aa62f6c629 100644 (file)
@@ -23,6 +23,7 @@ define Package/ustl
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C++ STL for embedded systems
+  DEPENDS:=@!TARGET_avr32
   URL:=http://ustl.sourceforge.net/
 endef
 
@@ -39,6 +40,8 @@ define Build/Configure
        $(CP) ./files/Common.mk $(PKG_BUILD_DIR)/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)