[packages] apr-util: update to 1.3.10 (CVE-2010-1623), use PKG_INSTALL and MAKE_FLAGS
[openwrt/svn-archive/archive.git] / libs / ustl / Makefile
index a4573ab99002293aff715106cf99e3709748fa6b..f467e9750b14d06f072bbdc0d8ecdc02db291bb8 100644 (file)
@@ -41,8 +41,6 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS="$(TARGET_CROSS)" \
                OPTFLAGS="$(TARGET_CFLAGS)" \
@@ -56,9 +54,9 @@ define Package/ustl/install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ustl* $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libustl.{a,so*} $(1)/usr/lib/
 endef