yapsnmp: fix annoying warning message
[openwrt/svn-archive/archive.git] / libs / yapsnmp / Makefile
index 53d4a442653ae70709030c1f7b778d1b691f993f..32d21aabceeb0eded09e4152458cb64849b370ee 100644 (file)
@@ -51,7 +51,9 @@ define Build/Compile
                all install
 endef
 
-pylibdir:=$(shell $(STAGING_DIR)/usr/bin/hostpython $(SCRIPT_DIR)/pylibdir.py)
+ifeq ($(DUMP),)
+  pylibdir:=$(shell $(STAGING_DIR)/usr/bin/hostpython $(SCRIPT_DIR)/pylibdir.py)
+endif
 define Package/yapsnmp/install
        $(INSTALL_DIR) $(1)$(pylibdir)
        $(CP) -a $(PKG_INSTALL_DIR)/* $(1)$(pylibdir)