[package] update dovecot to 1.2.9 (#6382)
[openwrt/svn-archive/archive.git] / mail / dovecot / Makefile
index 21c0d00adb46682fa3f9660199d79db771574a47..0e562f02a942f9188dac6bd01514c2af51848de7 100644 (file)
@@ -1,27 +1,26 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
-PKG_VERSION:=1.0.beta8
+PKG_VERSION:=1.2.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.dovecot.org/releases/
-PKG_MD5SUM:=6a87718a86ee1ae2334c75843dd9a7df
+PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
+PKG_MD5SUM:=036ff97fb248dae3bd4b796a0644634f
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl +librt
   TITLE:=An IMAP and POP3 daemon
   URL:=http://www.dovecot.org/
 endef
@@ -36,13 +35,25 @@ define Build/Configure
        );
        $(call Build/Configure/Default, \
                --without-gssapi \
+               --without-pam \
                --with-moduledir=/usr/lib/dovecot/modules \
+               --with-notify=dnotify \
                , \
-               ignore_signed_size=1 \
+               RPCGEN= \
+               i_cv_signed_size_t=no \
+               i_cv_signed_time_t=no \
+               i_cv_gmtime_max_time_t=32 \
+               i_cv_mmap_plays_with_write=yes \
+               i_cv_fd_passing=yes \
+               i_cv_c99_vsnprintf=yes \
+               lib_cv_va_copy=yes \
+               lib_cv_va_copy=yes \
+               lib_cv___va_copy=yes \
+               lib_cv_va_val_copy=yes \
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
@@ -51,8 +62,7 @@ endef
 define Package/dovecot/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
-       $(INSTALL_DIR) $(1)/etc/dovecot
-       $(INSTALL_DATA) ./files/dovecot.conf $(1)/etc/dovecot.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dovecot-example.conf $(1)/etc/dovecot.conf
        $(INSTALL_DIR) $(1)/usr/lib/dovecot
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -103,7 +113,3 @@ endef
 
 
 $(eval $(call BuildPackage,dovecot))
-
-$(eval $(call RequireCommand,autoconf, \
-       $(PKG_NAME) requires GNU autoconf. \
-))