opennhrp: Enable parallel build
[openwrt/svn-archive/archive.git] / mail / dovecot / Makefile
index 21c0d00adb46682fa3f9660199d79db771574a47..614cc18e412fd9627b69a11d36210235fe7ca0a2 100644 (file)
@@ -1,27 +1,29 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
-PKG_VERSION:=1.0.beta8
+PKG_VERSION:=1.2.13
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.dovecot.org/releases/
-PKG_MD5SUM:=6a87718a86ee1ae2334c75843dd9a7df
+PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
+PKG_MD5SUM:=aaee3b5fd59e01780305553248f686bc
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl +librt
   TITLE:=An IMAP and POP3 daemon
   URL:=http://www.dovecot.org/
 endef
@@ -30,29 +32,36 @@ define Package/dovecot/description
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
+CONFIGURE_ARGS += \
+       --without-gssapi \
+       --without-pam \
+       --with-moduledir=/usr/lib/dovecot/modules \
+       --with-notify=dnotify \
+
+CONFIGURE_VARS += \
+       RPCGEN= \
+       i_cv_signed_size_t=no \
+       i_cv_signed_time_t=no \
+       i_cv_gmtime_max_time_t=32 \
+       i_cv_mmap_plays_with_write=yes \
+       i_cv_fd_passing=yes \
+       i_cv_c99_vsnprintf=yes \
+       lib_cv_va_copy=yes \
+       lib_cv_va_copy=yes \
+       lib_cv___va_copy=yes \
+       lib_cv_va_val_copy=yes \
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                autoconf \
        );
-       $(call Build/Configure/Default, \
-               --without-gssapi \
-               --with-moduledir=/usr/lib/dovecot/modules \
-               , \
-               ignore_signed_size=1 \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Configure/Default)
 endef
 
 define Package/dovecot/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
-       $(INSTALL_DIR) $(1)/etc/dovecot
-       $(INSTALL_DATA) ./files/dovecot.conf $(1)/etc/dovecot.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dovecot-example.conf $(1)/etc/dovecot.conf
        $(INSTALL_DIR) $(1)/usr/lib/dovecot
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -103,7 +112,3 @@ endef
 
 
 $(eval $(call BuildPackage,dovecot))
-
-$(eval $(call RequireCommand,autoconf, \
-       $(PKG_NAME) requires GNU autoconf. \
-))