[packages] darkstat: update to 3.0.713, use PKG_INSTALL and Build/Compile/Default...
[openwrt/svn-archive/archive.git] / mail / dovecot / Makefile
index 44840aa306371e00e878b995713d4d10805bdcc9..70383284f95a72de111ab81e347f6f1f37150fee 100644 (file)
@@ -1,27 +1,29 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
-PKG_VERSION:=1.1.2
-PKG_RELEASE:=1
+PKG_VERSION:=1.2.10
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.1
-PKG_MD5SUM:=fcebb6c099421049632b2f1f019f55cd
+PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
+PKG_MD5SUM:=b7d0081b17ff6afae85e8dc14157fa57
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl +zlib
+  DEPENDS:=+libopenssl +librt
   TITLE:=An IMAP and POP3 daemon
   URL:=http://www.dovecot.org/
 endef
@@ -30,39 +32,36 @@ define Package/dovecot/description
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
+CONFIGURE_ARGS += \
+       --without-gssapi \
+       --without-pam \
+       --with-moduledir=/usr/lib/dovecot/modules \
+       --with-notify=dnotify \
+
+CONFIGURE_VARS += \
+       RPCGEN= \
+       i_cv_signed_size_t=no \
+       i_cv_signed_time_t=no \
+       i_cv_gmtime_max_time_t=32 \
+       i_cv_mmap_plays_with_write=yes \
+       i_cv_fd_passing=yes \
+       i_cv_c99_vsnprintf=yes \
+       lib_cv_va_copy=yes \
+       lib_cv_va_copy=yes \
+       lib_cv___va_copy=yes \
+       lib_cv_va_val_copy=yes \
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                autoconf \
        );
-       $(call Build/Configure/Default, \
-               --without-gssapi \
-               --with-moduledir=/usr/lib/dovecot/modules \
-               --with-notify=dnotify \
-               , \
-               RPCGEN= \
-               i_cv_signed_size_t=no \
-               i_cv_signed_time_t=no \
-               i_cv_gmtime_max_time_t=32 \
-               i_cv_mmap_plays_with_write=yes \
-               i_cv_fd_passing=yes \
-               i_cv_c99_vsnprintf=yes \
-               lib_cv_va_copy=yes \
-               lib_cv_va_copy=yes \
-               lib_cv___va_copy=yes \
-               lib_cv_va_val_copy=yes \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Configure/Default)
 endef
 
 define Package/dovecot/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/dovecot-example.conf $(1)/etc/dovecot.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dovecot-example.conf $(1)/etc/dovecot.conf
        $(INSTALL_DIR) $(1)/usr/lib/dovecot
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
        $(INSTALL_DIR) $(1)/usr/sbin