[packages] fetchmail: update to 6.3.19, add ssl/nossl variants
[openwrt/svn-archive/archive.git] / mail / fetchmail / Makefile
index 3011679138857380c7e641ca4de3db76214cdeb8..a85ec05e6c42dbeb83f288e7a79410cc3f42ff64 100644 (file)
@@ -1,53 +1,83 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fetchmail
-PKG_VERSION:=6.2.5
+PKG_VERSION:=6.3.19
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
-PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.berlios.de/fetchmail
+PKG_MD5SUM:=64519711c8533f5a34d20c9ff620d880
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/fetchmail
+define Package/fetchmail/Default
   SECTION:=mail
   CATEGORY:=Mail
   TITLE:=Remote mail retriever
-  URL:=http://www.catb.org/~esr/fetchmail/
+  URL:=http://fetchmail.berlios.de/
 endef
 
-define Package/fetchmail/description
+define Package/fetchmail/Default/description
  Retrieves remote mail via POP/IMAP.
  Very useful in conjunction with mutt.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-fallback=procmail \
-               --without-hesiod \
-               , \
-               ac_cv_path_procmail=/usr/sbin/procmail \
-       )
+define Package/fetchmail
+  $(call Package/fetchmail/Default)
+  DEPENDS+= +libopenssl
+  TITLE+= (with SSL support)
+  VARIANT:=ssl
+endef
+
+define Package/fetchmail/description
+ $(call Package/fetchmail/Default/description)
+ This package is built with SSL support.
+endef
+
+define Package/fetchmail-nossl
+  $(call Package/fetchmail/Default)
+  TITLE+= (without SSL support)
+  VARIANT:=nossl
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/fetchmail-nossl/description
+ $(call Package/fetchmail/Default/description)
+ This package is built without SSL support.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-fallback=procmail \
+       --without-hesiod
+
+ifeq ($(BUILD_VARIANT),ssl)
+       CONFIGURE_ARGS += \
+               --with-ssl="$(STAGING_DIR)/usr"
+endif
+
+ifeq ($(BUILD_VARIANT),nossl)
+       CONFIGURE_ARGS += \
+               --without-ssl
+endif
+
+CONFIGURE_VARS += \
+       ac_cv_path_procmail=/usr/sbin/procmail
+
 define Package/fetchmail/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fetchmail $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/fetchmail $(1)/usr/bin/
 endef
 
+Package/fetchmail-nossl/install = $(Package/fetchmail/install)
+
 $(eval $(call BuildPackage,fetchmail))
+$(eval $(call BuildPackage,fetchmail-nossl))