[package] update faifa to r55, patch from Raphael Huck.
[openwrt/svn-archive/archive.git] / mail / ssmtp / Makefile
index 35ed4d72610825e177d55e89b752615ffc7e2503..93b0fe50a41f76388c40472f35e11fc7d0e6307d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssmtp
-PKG_VERSION:=2.63
+PKG_VERSION:=2.64
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp/
-PKG_MD5SUM:=
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.bz2
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp
+PKG_MD5SUM:=65b4e0df4934a6cd08c506cabcbe584f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,26 +24,31 @@ define Package/ssmtp
   CATEGORY:=Mail
   DEPENDS:=+libopenssl
   TITLE:=A minimal and secure mail sender
-  URL:=http://packages.debian.org/stable/mail/ssmtp
+  URL:=http://packages.debian.org/ssmtp
 endef
 
 define Package/ssmtp/description
- A secure, effective and simple way of getting mail off a system to your 
- mail hub. It contains no suid-binaries or other dangerous things - no 
+ A secure, effective and simple way of getting mail off a system to your
+ mail hub. It contains no suid-binaries or other dangerous things - no
  mail spool to poke around in, and no daemons running in the background.
- mail is simply forwarded to the configured mailhost. Extremely easy 
+ mail is simply forwarded to the configured mailhost. Extremely easy
  configuration.
 endef
 
+define Package/ssmtp/conffiles
+/etc/ssmtp/ssmtp.conf
+/etc/ssmtp/revaliases
+endef
+
 CONFIGURE_VARS += \
        LIBS="$(TARGET_LDFLAGS) -lcrypto -lssl"
 
 CONFIGURE_ARGS += \
        --enable-ssl
 
-define Package/ssmtp/install   
+define Package/ssmtp/install
        $(INSTALL_DIR) $(1)/etc/ssmtp
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/ssmtp.conf $(1)/etc/ssmtp/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ssmtp.conf $(1)/etc/ssmtp/
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/revaliases $(1)/etc/ssmtp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ssmtp $(1)/usr/sbin/