[packages] ssmtp: update to 2.64 (#6467)
[openwrt/svn-archive/archive.git] / mail / ssmtp / Makefile
index 6e6ef67f012a7f63d003258fb80b7d8b43a66920..93b0fe50a41f76388c40472f35e11fc7d0e6307d 100644 (file)
@@ -1,48 +1,54 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssmtp
-PKG_VERSION:=2.61
-PKG_RELEASE:=2
+PKG_VERSION:=2.64
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp/
-PKG_MD5SUM:=957e6fff08625fe34f4fc33d0925bbc9
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.bz2
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp
+PKG_MD5SUM:=65b4e0df4934a6cd08c506cabcbe584f
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(TARGET_CPPFLAGS)
+
 define Package/ssmtp
   SECTION:=mail
   CATEGORY:=Mail
   DEPENDS:=+libopenssl
   TITLE:=A minimal and secure mail sender
-  URL:=http://packages.debian.org/stable/mail/ssmtp
+  URL:=http://packages.debian.org/ssmtp
 endef
 
 define Package/ssmtp/description
- A secure, effective and simple way of getting mail off a system to your 
- mail hub. It contains no suid-binaries or other dangerous things - no 
+ A secure, effective and simple way of getting mail off a system to your
+ mail hub. It contains no suid-binaries or other dangerous things - no
  mail spool to poke around in, and no daemons running in the background.
- mail is simply forwarded to the configured mailhost. Extremely easy 
+ mail is simply forwarded to the configured mailhost. Extremely easy
  configuration.
 endef
 
-TARGET_CONFIGURE_OPTS += \
-       CC="$(TARGET_CC) $(EXTRA_CFLAGS) $(EXTRA_LDFLAGS)"
+define Package/ssmtp/conffiles
+/etc/ssmtp/ssmtp.conf
+/etc/ssmtp/revaliases
+endef
+
+CONFIGURE_VARS += \
+       LIBS="$(TARGET_LDFLAGS) -lcrypto -lssl"
 
 CONFIGURE_ARGS += \
        --enable-ssl
 
-define Package/ssmtp/install   
+define Package/ssmtp/install
        $(INSTALL_DIR) $(1)/etc/ssmtp
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/ssmtp.conf $(1)/etc/ssmtp/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ssmtp.conf $(1)/etc/ssmtp/
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/revaliases $(1)/etc/ssmtp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ssmtp $(1)/usr/sbin/