[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / mail / ssmtp / Makefile
index 9c9c566ef3e16008b5595fd10c8e69003023d7d8..ded1a32980d45c9083a2c0809916fa81cdbe1b75 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -18,7 +17,7 @@ PKG_MD5SUM:=957e6fff08625fe34f4fc33d0925bbc9
 
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += $(TARGET_CPPFLAGS)
 
 define Package/ssmtp
   SECTION:=mail
@@ -37,7 +36,7 @@ define Package/ssmtp/description
 endef
 
 CONFIGURE_VARS += \
-       LIBS="-L$(STAGING_DIR)/usr/lib -lcrypto -lssl"
+       LIBS="$(TARGET_LDFLAGS) -lcrypto -lssl"
 
 CONFIGURE_ARGS += \
        --enable-ssl