[packages] darkstat: update to 3.0.713, use PKG_INSTALL and Build/Compile/Default...
[openwrt/svn-archive/archive.git] / mail / xmail / Makefile
index dff4f0673d1b76d0e25d39d521e5220bc1f8f9b3..fb316b39f9274d19dfd376b14425d35a8ebe20ac 100644 (file)
@@ -1,27 +1,26 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xmail
-PKG_VERSION:=1.25
+PKG_VERSION:=1.26
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xmailserver.org/
-PKG_MD5SUM:=675baa512a97057c9e63905272406b69
+PKG_MD5SUM:=26d35c2fc104d79ebb6397c7dece5b15
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xmail
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+uclibcxx +libopenssl
+  DEPENDS:=+uclibcxx +libopenssl +libpthread
   TITLE:=advanced, fast and reliable ESMTP/POP3 mail server
   URL:=http://www.xmailserver.org/
 endef
@@ -32,10 +31,6 @@ define Package/xmail/description
  multiple domains, virtual users and spam protection.
 endef
 
-define Build/Configure
-       $(CP) ./files/SysMachine.h $(PKG_BUILD_DIR)/
-endef
-
 define Build/Compile
        CFLAGS="$(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lnx \
@@ -44,13 +39,18 @@ define Build/Compile
                CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
                LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -lcrypto -lssl -luClibc++ -ldl -lm -lpthread" \
                all
+       tar -cjf $(PKG_BUILD_DIR)/MailRoot.tar.bz2 -C $(PKG_BUILD_DIR)/MailRoot --exclude bin .
 endef
 
 define Package/xmail/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/* $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/var/MailRoot/
-       $(CP) $(PKG_BUILD_DIR)/MailRoot $(1)/var/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/MailRoot.tar.bz2 $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/xmail.config $(1)/etc/config/xmail
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/xmail.init $(1)/etc/init.d/xmail
 endef
 
 $(eval $(call BuildPackage,xmail))