[packages] ffmpeg: add workarounds for build failure on x86
[openwrt/svn-archive/archive.git] / multimedia / ffmpeg / Makefile
index 6d496ccd3b2c744e052d32a01dac784d12dd6d8a..05136af11672093ef83982173bddd343567dcc66 100644 (file)
@@ -163,10 +163,15 @@ FFMPEG_CONFIGURE_DEMUXERS:=$(call FILTER_CONFIG,DEMUXER,demuxer,$(FFMPEG_DEMUXER
 FFMPEG_CONFIGURE_PARSERS:=$(call FILTER_CONFIG,PARSER,parser,$(FFMPEG_PARSERS))
 FFMPEG_CONFIGURE_PROTOCOLS:=$(call FILTER_CONFIG,PROTOCOL,protocol,$(FFMPEG_PROTOCOLS))
 
+# XXX: add --disable-mmx & --disable-mmx2 to fix build failure on x86
+# libpostproc/postprocess_template.c:2195: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+# libpostproc/postprocess_template.c:3124: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+# libpostproc/postprocess_template.c:3207: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                ./configure \
                --enable-cross-compile \
@@ -180,6 +185,8 @@ define Build/Configure
                --enable-ffserver \
                --enable-gpl \
                --enable-libfaad \
+               --disable-mmx \
+               --disable-mmx2 \
                --enable-pthreads \
                --disable-optimizations \
                --enable-small \