Fix libproc installation (#1389)
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index aa3fb49ca7b116a296686b56a2850946dcd16380..2af8dfe80adf957ebcad553edd36d5e707b17c9c 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -31,11 +31,6 @@ define Package/gphoto2
   URL:=http://www.gphoto.org/
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libiconv-prefix \
@@ -47,8 +42,6 @@ define Build/Configure
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
-               ac_cv_c_bigendian="$(BIG_ENDIAN)" \
-               ac_cv_func_malloc_0_nonnull=yes \
        )
 endef
 
@@ -59,7 +52,7 @@ define Build/Compile
 endef
 
 define Package/gphoto2/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
 endef