[Packages] multimedia/gphoto2: Update to 2.4.0
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index 694e57f929f05936bfa0cf1d2ffe1bff4725f76c..30b2a8753f032c0d361b255f41059d6cfd421c86 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gphoto2
-PKG_VERSION:=2.2.0
+PKG_VERSION:=2.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
-PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84
-PKG_CAT:=bzcat
+PKG_MD5SUM:=5fd1f711ca806adb687b33c55964d898
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,33 +29,24 @@ define Package/gphoto2
 endef
 
 define Package/gphoto2/description
-For downloading and controlling digital cameras
+       For downloading and controlling digital cameras
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-libiconv-prefix \
-               --without-libintl-prefix \
-               , \
-               LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
-               LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
-               LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
-               LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
-               POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
-               POPT_LIBS="$$$$LDFLAGS -lpopt" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
+       LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
+       LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+       LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
+       POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+       POPT_LIBS="$$$$LDFLAGS -lpopt" \
 
 define Package/gphoto2/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gphoto2/$(PKG_NAME) $(1)/usr/bin/
 endef
 
-
 $(eval $(call BuildPackage,gphoto2))