make XOrg depend on DISPLAY_SUPPORT instead of TARGET_x86, see [9448]
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index 38b44879333887dd74e0b1e3e70c1472f3e6d5bf..38f9443190e972a418ce8c975feea122bdb1557d 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
 PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84
-PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,10 +26,13 @@ define Package/gphoto2
   CATEGORY:=Multimedia
   DEPENDS:=+libexif +libgphoto2 +libltdl +libpopt +libpthread
   TITLE:=Gphoto Digital Camera Control
-  DESCRIPTION:=For downloading and controlling digital cameras
   URL:=http://www.gphoto.org/
 endef
 
+define Package/gphoto2/description
+For downloading and controlling digital cameras
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libiconv-prefix \
@@ -52,7 +54,7 @@ define Build/Compile
 endef
 
 define Package/gphoto2/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
 endef