fix ettercap compile
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index 73ab2fd1be280d8444a51c0dfd5a5aae32f06da9..4e1a3dca6327478b6e06c00b14a48a6c1adae9ae 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
 PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
 PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84
-PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,20 +26,12 @@ define Package/gphoto2
   CATEGORY:=Multimedia
   DEPENDS:=+libexif +libgphoto2 +libltdl +libpopt +libpthread
   TITLE:=Gphoto Digital Camera Control
   CATEGORY:=Multimedia
   DEPENDS:=+libexif +libgphoto2 +libltdl +libpopt +libpthread
   TITLE:=Gphoto Digital Camera Control
-  DESCRIPTION:=For downloading and controlling digital cameras
   URL:=http://www.gphoto.org/
 endef
 
   URL:=http://www.gphoto.org/
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(ARCH),mips)
-  BIG_ENDIAN:=yes
-endif
-ifeq ($(ARCH),armeb)
-  BIG_ENDIAN:=yes
-endif
-ifeq ($(ARCH),powerpc)
-  BIG_ENDIAN:=yes
-endif
+define Package/gphoto2/description
+For downloading and controlling digital cameras
+endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
 
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -53,8 +44,6 @@ define Build/Configure
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
-               ac_cv_c_bigendian="$(BIG_ENDIAN)" \
-               ac_cv_func_malloc_0_nonnull=yes \
        )
 endef
 
        )
 endef
 
@@ -65,8 +54,8 @@ define Build/Compile
 endef
 
 define Package/gphoto2/install
 endef
 
 define Package/gphoto2/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
 endef
 
 
 endef