DESCRIPTION:= is obselete
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index aa3fb49ca7b116a296686b56a2850946dcd16380..694e57f929f05936bfa0cf1d2ffe1bff4725f76c 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,14 +27,12 @@ define Package/gphoto2
   CATEGORY:=Multimedia
   DEPENDS:=+libexif +libgphoto2 +libltdl +libpopt +libpthread
   TITLE:=Gphoto Digital Camera Control
-  DESCRIPTION:=For downloading and controlling digital cameras
   URL:=http://www.gphoto.org/
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
+define Package/gphoto2/description
+For downloading and controlling digital cameras
+endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -47,8 +45,6 @@ define Build/Configure
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
-               ac_cv_c_bigendian="$(BIG_ENDIAN)" \
-               ac_cv_func_malloc_0_nonnull=yes \
        )
 endef
 
@@ -59,7 +55,7 @@ define Build/Compile
 endef
 
 define Package/gphoto2/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
 endef