[packages] add hasciicam, a tool to stream live ascii video feeds
[openwrt/svn-archive/archive.git] / multimedia / gphoto2 / Makefile
index aa3fb49ca7b116a296686b56a2850946dcd16380..dda5121c2ffd0f8adf59679a1fa7d4669bac978b 100644 (file)
@@ -1,24 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gphoto2
-PKG_VERSION:=2.2.0
+PKG_VERSION:=2.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
-PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84
-PKG_CAT:=bzcat
+PKG_MD5SUM:=fba6cf5f5d6a23569d97f4f6896d5e09
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,41 +24,28 @@ define Package/gphoto2
   CATEGORY:=Multimedia
   DEPENDS:=+libexif +libgphoto2 +libltdl +libpopt +libpthread
   TITLE:=Gphoto Digital Camera Control
-  DESCRIPTION:=For downloading and controlling digital cameras
   URL:=http://www.gphoto.org/
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-libiconv-prefix \
-               --without-libintl-prefix \
-               , \
-               LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
-               LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
-               LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
-               LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
-               POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
-               POPT_LIBS="$$$$LDFLAGS -lpopt" \
-               ac_cv_c_bigendian="$(BIG_ENDIAN)" \
-               ac_cv_func_malloc_0_nonnull=yes \
-       )
+define Package/gphoto2/description
+       For downloading and controlling digital cameras
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+
+CONFIGURE_VARS += \
+       LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
+       LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
+       LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+       LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
+       POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+       POPT_LIBS="$$$$LDFLAGS -lpopt" \
 
 define Package/gphoto2/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gphoto2/$(PKG_NAME) $(1)/usr/bin/
 endef
 
-
 $(eval $(call BuildPackage,gphoto2))