[packages] gst-plugins: Add debugging information
[openwrt/svn-archive/archive.git] / multimedia / gst-plugins-bad / Makefile
index c792ff10907820d4bec29058d74b261078ff3643..f7214b8c36c3e6c9fd69d3cbaef73f6523f5404b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst-plugins-bad
-PKG_VERSION:=0.10.19
+PKG_VERSION:=0.10.23
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
-PKG_MD5SUM:=368f72e2a1c7a6e8fe60394e4315259b
+PKG_MD5SUM:=e4822fa2cc933768e2998311a1565979
 
 PKG_BUILD_DEPENDS:= gstreamer gst-plugins-base liboil
 
@@ -52,7 +52,6 @@ endef
 GST_VERSION:=0.10
 
 CONFIGURE_ARGS += \
-       --disable-debug \
        --disable-examples \
        --disable-nls   \
        \
@@ -77,7 +76,6 @@ CONFIGURE_ARGS += \
        --disable-resindvd \
        --disable-metadata \
        --disable-faac \
-       --disable-faad \
        --disable-fbdev \
        --disable-flite \
        --disable-gsm \
@@ -129,6 +127,38 @@ define Package/gst-plugins-ugly/install
        /bin/true
 endef
 
+# 1: short name
+# 2: description
+# 3: dependencies on other gstreamer libraries (short name)
+# 4: dependencies on other packages
+define GstBuildLibrary
+
+  GST_DEPENDS += +libgst$(1)
+
+  define Package/libgst$(1)
+    $(call Package/gstreamer/Default)
+    TITLE+= $(2) library (base)
+    DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $(4)
+  endef
+
+  define Package/libgst$(1)/description
+   $(call Package/gstreamer/description/Default)
+   .
+   This package contains the GStreamer $(2) library.
+  endef
+
+  define Package/libgst$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
+               $$(1)/usr/lib/ \
+       )
+  endef
+
+  $$(eval $$(call BuildPackage,libgst$(1)))
+endef
+$(eval $(call GstBuildLibrary,photography,photography,,))
+
 
 # 1: short name
 # 2: description
@@ -164,56 +194,51 @@ endef
 
 $(eval $(call GstBuildPlugin,adpcmdec,adpcm decoding support,,,))
 $(eval $(call GstBuildPlugin,adpcmenc,adpcm encoding support,,,))
-$(eval $(call GstBuildPlugin,aiff,aiff support,,,))
-$(eval $(call GstBuildPlugin,asfmux,asf muxing support,,,))
-$(eval $(call GstBuildPlugin,audioparsersbad,audioparsers support,,,))
+$(eval $(call GstBuildPlugin,aiff,aiff support,tag,,))
+$(eval $(call GstBuildPlugin,asfmux,asf muxing support,rtp,,))
 $(eval $(call GstBuildPlugin,autoconvert,autoconvert support,,,))
-$(eval $(call GstBuildPlugin,camerabin,camerabin support,,,))
-$(eval $(call GstBuildPlugin,legacyresample,legacyresample support,,,))
-$(eval $(call GstBuildPlugin,bayer,bayer support,,,))
-$(eval $(call GstBuildPlugin,cdxaparse,cdxaparse support,,,))
+$(eval $(call GstBuildPlugin,camerabin,camerabin support,interfaces photography tag,,))
+$(eval $(call GstBuildPlugin,legacyresample,legacyresample support,,,+liboil +librt))
+$(eval $(call GstBuildPlugin,bayer,bayer support,video,,))
+$(eval $(call GstBuildPlugin,cdxaparse,cdxaparse support,riff,,))
 $(eval $(call GstBuildPlugin,dataurisrc,dataurisrc support,,,))
 $(eval $(call GstBuildPlugin,dccp,dccp support,,,))
-$(eval $(call GstBuildPlugin,debugutilsbad,debugutils support,,,))
-$(eval $(call GstBuildPlugin,dtmf,dtmf support,,,))
-$(eval $(call GstBuildPlugin,dvdspu,dvdspu support,,,))
-$(eval $(call GstBuildPlugin,festival,festival support,,,))
+$(eval $(call GstBuildPlugin,debugutilsbad,debugutils support,interfaces video,,))
+$(eval $(call GstBuildPlugin,dtmf,dtmf support,rtp,,))
+$(eval $(call GstBuildPlugin,dvdspu,dvdspu support,video,,))
+$(eval $(call GstBuildPlugin,faad,faad support,audio,,+libfaad2))
+$(eval $(call GstBuildPlugin,festival,festival support,audio,,))
 $(eval $(call GstBuildPlugin,freeze,freeze support,,,))
-$(eval $(call GstBuildPlugin,frei0r,frei0r support,,,))
+$(eval $(call GstBuildPlugin,frei0r,frei0r support,controller video,,))
 $(eval $(call GstBuildPlugin,h264parse,h264parse support,,,))
 $(eval $(call GstBuildPlugin,hdvparse,hdvparse support,,,))
-$(eval $(call GstBuildPlugin,id3tag,id3tag support,,,))
-$(eval $(call GstBuildPlugin,invtelecine,invtelecine support,,,))
-$(eval $(call GstBuildPlugin,jpegformat,jpegformat support,,,))
-#$(eval $(call GstBuildPlugin,librfbsrc,librfb support,,,))
-$(eval $(call GstBuildPlugin,liveadder,liveadder support,,,))
-$(eval $(call GstBuildPlugin,mpegdemux,mpegdemux support,,,))
-$(eval $(call GstBuildPlugin,mpegtsmux,mpegtsmux support,,,))
+$(eval $(call GstBuildPlugin,id3tag,id3tag support,tag,,))
+$(eval $(call GstBuildPlugin,jpegformat,jpegformat support,tag interfaces,,))
+$(eval $(call GstBuildPlugin,liveadder,liveadder support,audio,,))
+$(eval $(call GstBuildPlugin,mpegdemux,mpegdemux support,tag,,+liboil +librt))
+$(eval $(call GstBuildPlugin,mpegtsmux,mpegtsmux support,video,,))
 $(eval $(call GstBuildPlugin,mpegpsmux,mpegpsmux support,,,))
-$(eval $(call GstBuildPlugin,mpeg4videoparse,mpeg4videoparse support,,,))
 $(eval $(call GstBuildPlugin,mpegvideoparse,mpegvideoparse support,,,))
 $(eval $(call GstBuildPlugin,mve,mve support,,,))
-$(eval $(call GstBuildPlugin,mxf,mxf support,,,))
+$(eval $(call GstBuildPlugin,mxf,mxf support,video,,))
 $(eval $(call GstBuildPlugin,nsf,nsf support,,,))
 $(eval $(call GstBuildPlugin,nuvdemux,nuvdemux support,,,))
 $(eval $(call GstBuildPlugin,pcapparse,pcapparse support,,,))
-$(eval $(call GstBuildPlugin,pnm,pnm support,,,))
-$(eval $(call GstBuildPlugin,qtmux,qtmux support,,,))
-$(eval $(call GstBuildPlugin,rawparse,rawparse support,,,))
-$(eval $(call GstBuildPlugin,rtpmux,rtpmux support,,,))
+$(eval $(call GstBuildPlugin,pnm,pnm support,video,,))
+$(eval $(call GstBuildPlugin,rawparse,rawparse support,video audio,,))
+$(eval $(call GstBuildPlugin,rtpmux,rtpmux support,rtp,,))
 #$(eval $(call GstBuildPlugin,rfbsrc,rfb support,,,))
 $(eval $(call GstBuildPlugin,scaletempoplugin,scaletempo support,,,))
-$(eval $(call GstBuildPlugin,sdpelem,sdp support,,,))
-$(eval $(call GstBuildPlugin,segmentclip,segmentclip support,,,))
-$(eval $(call GstBuildPlugin,selector,selector support,,,))
-$(eval $(call GstBuildPlugin,siren,siren support,,,))
+$(eval $(call GstBuildPlugin,sdpelem,sdp support,interfaces rtp sdp,,))
+$(eval $(call GstBuildPlugin,segmentclip,segmentclip support,audio,,))
+$(eval $(call GstBuildPlugin,siren,siren support,rtp,,))
+#$(eval $(call GstBuildPlugin,soundtouch,soundtouch support,,,))
 $(eval $(call GstBuildPlugin,speed,speed support,,,))
-$(eval $(call GstBuildPlugin,subenc,subenc support,,,))
-$(eval $(call GstBuildPlugin,stereo,stereo support,,,))
+$(eval $(call GstBuildPlugin,subenc,subenc support,controller,,))
+$(eval $(call GstBuildPlugin,stereo,stereo support,audio controller,,))
 $(eval $(call GstBuildPlugin,tta,tta support,,,))
-$(eval $(call GstBuildPlugin,valve,valve support,,,))
-$(eval $(call GstBuildPlugin,videomeasure,videomeasure support,,,))
-$(eval $(call GstBuildPlugin,videosignal,videosignal support,,,))
+$(eval $(call GstBuildPlugin,videomeasure,videomeasure support,video,,))
+$(eval $(call GstBuildPlugin,videosignal,videosignal support,video,,))
 $(eval $(call GstBuildPlugin,vmnc,vmnc support,,,))
 $(eval $(call GstBuildPlugin,mms,mms support,,,+libmms))