Cleanup makefile and fix compilation
[openwrt/svn-archive/archive.git] / multimedia / gst-plugins-base / Makefile
index 6221b8e863660be69e0bb28ad95b751a3e8815e1..0ede23de52023123429de00796f8198a608cfc14 100644 (file)
@@ -33,14 +33,10 @@ define Package/gst-plugins-base/description
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               if [ -x $(CONFIGURE_CMD) ]; then \
-                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-                       $(CONFIGURE_VARS) \
-                       $(CONFIGURE_CMD) \
-                       --disable-ogg --disable-vorbis\
-                       $(CONFIGURE_ARGS) ;\
-               fi \
+       $(call Build/Configure/Default,\
+               --disable-ogg \
+               --disable-vorbis \
+               --without-x \
        )
 endef