[packages] gstreamer: update to 0.10.29, rework Makefile:
[openwrt/svn-archive/archive.git] / multimedia / gst-plugins-good / Makefile
index d8b757376db161ca38d63537a538dbda339dfcc5..a43d4d4cdf6931b490415c664a07208cd200c4b8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst-plugins-good
 PKG_VERSION:=0.10.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
@@ -36,7 +36,7 @@ EXTRA_LDFLAGS+= \
 define Package/gst-plugins-good/Default
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+gstreamer +gst-plugins-base
+  DEPENDS:=+gstreamer +gst-plugins-base-libgsttag +gst-plugins-base-libgstpbutils
   TITLE:=gst-plugins-good
   URL:=http://gstreamer.freedesktop.org/
 endef
@@ -82,17 +82,17 @@ define Build/Configure
                --disable-sunaudio \
                --without-x \
        )
-       mkdir -p $(PKG_BUILD_DIR)/bin
+       $(INSTALL_DIR) $(PKG_BUILD_DIR)/bin
        touch $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
        chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
 endef
 
 define BuildPlugin
   define Package/gst-plugins-good-$(1)/install
-       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
+       $(INSTALL_DIR) $$(1)/usr/lib/gstreamer-0.10
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgst$(1).so \
-               $(1)/usr/lib/gstreamer-0.10
+               $$(1)/usr/lib/gstreamer-0.10
   endef
 
   $$(eval $$(call BuildPackage,gst-plugins-good-$(1)))