[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / multimedia / hasciicam / Makefile
index a5e695e0c433c4ea796be544469390a12ae2e098..18e5fd99f8548bf38a6eb44522b5a399e7950729 100644 (file)
@@ -17,6 +17,8 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=262f56eb307f9a0d4bee04d38e0adde7e4257d87
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hasciicam
@@ -31,13 +33,7 @@ endef
 CONFIGURE_VARS += \
        LIBS="-lncurses" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/hasciicam/install       
+define Package/hasciicam/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hasciicam $(1)/usr/bin/
 endef