[package] update libIDL2 to 0.8.13 (#5924)
[openwrt/svn-archive/archive.git] / multimedia / linux-uvc / Makefile
index 54a4310cc911ba3ca4039d601d0f6e52e821fad1..1331abfec102dc0b0e890b90d247adaf74feabd3 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -22,11 +21,11 @@ PKG_SOURCE_PROTO:=svn
 
 include $(INCLUDE_DIR)/package.mk
 
-define KernelPackage/video-uvc
+define KernelPackage/video-uvc-obsolete
   SUBMENU:=Video Support
-  TITLE:=USB Video Class (UVC) support
+  TITLE:=USB Video Class (UVC) support (obsolete)
   URL:=http://linux-uvc.berlios.de/
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+  DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24||LINUX_2_6_25 @USB_SUPPORT +kmod-usb-core +kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
 endef
@@ -40,4 +39,4 @@ define Build/Compile
                modules
 endef
 
-$(eval $(call KernelPackage,video-uvc))
+$(eval $(call KernelPackage,video-uvc-obsolete))