[package] update mjpg-streamer to r94 (#7491)
[openwrt/svn-archive/archive.git] / multimedia / mjpg-streamer / Makefile
index 53b97026695479c3a13d2b772b0d33661f2b533d..e9637db3e108a0a5feeb83cef79a507be5b6ce17 100644 (file)
@@ -1,17 +1,16 @@
 #
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mjpg-streamer
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mjpg-streamer
-PKG_REV:=68
+PKG_REV:=94
 PKG_VERSION:=r$(PKG_REV)
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/
@@ -26,23 +25,27 @@ define Package/mjpg-streamer
   CATEGORY:=Multimedia
   TITLE:=MJPG-streamer
   DEPENDS:=@LINUX_2_6 +libpthread +libjpeg
   CATEGORY:=Multimedia
   TITLE:=MJPG-streamer
   DEPENDS:=@LINUX_2_6 +libpthread +libjpeg
-  URL:=http://www.naaa.de/uvc_streamer.htm
+  URL:=http://mjpg-streamer.wiki.sourceforge.net/
 endef
 
 define Package/mjpg-streamer/description
        Streaming application for Linux-UVC compatible webcams
 endef
 
 endef
 
 define Package/mjpg-streamer/description
        Streaming application for Linux-UVC compatible webcams
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)
 
 define Package/mjpg-streamer/install
 
 define Package/mjpg-streamer/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(CP) ./files/mjpg-streamer.config $(1)/etc/config/mjpg-streamer
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mjpg-streamer.init $(1)/etc/init.d/mjpg-streamer
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach input_plugin,uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib
+       $(CP) $(foreach input_plugin,file uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib
        $(CP) $(foreach output_plugin,http file autofocus,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib
        $(CP) $(foreach output_plugin,http file autofocus,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib
-       $(INSTALL_DIR) $(1)/webcam_www
-       $(CP) $(PKG_BUILD_DIR)/www/* $(1)/webcam_www
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
+       $(INSTALL_DATA) ./files/mjpg-streamer.hotplug $(1)/etc/hotplug.d/usb/20-mjpg-streamer
 endef
 
 $(eval $(call BuildPackage,mjpg-streamer))
 endef
 
 $(eval $(call BuildPackage,mjpg-streamer))