massive Makefile cleanup, add missing 'svn:keywords' property
[openwrt/svn-archive/archive.git] / multimedia / motion / Makefile
index a29d90a3cc61811856c5731ba7ab77c724c7d9e1..512617c9d0194d2e1d86a33242a3039ca4a53c6a 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=motion
 PKG_VERSION:=3.2.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 
-PKG_SOURCE_URL:=@SF/motion
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/motion
+PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -27,29 +27,34 @@ define Package/motion
   CATEGORY:=Multimedia
   DEPENDS:=+libjpeg
   TITLE:=webcam motion sensing and logging
-  DESCRIPTION:=Motion is a software motion detector
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
 
+define Package/motion/conffiles
+/etc/motion.conf
+endef
+
 define Build/Configure
-$(call Build/Configure/Default,--without-ffmpeg \
-                       --without-jpeg-mmx \
-                       --without-mysql \
-                       --without-pgsql \
-)
+       $(call Build/Configure/Default, \
+               --without-ffmpeg \
+               --without-jpeg-mmx \
+               --without-mysql \
+               --without-pgsql \
+       )
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/motion/install  
+       install -d -m0755 $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
        install -d -m0755 $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
+
 endef
 
 $(eval $(call BuildPackage,motion))