[packages] motion: update to v3.2.11.1, add dependency on libpthread, cleanup
[openwrt/svn-archive/archive.git] / multimedia / motion / Makefile
index 7b46573aecd3c2f604c3de04fc424e3c73ad294a..98b4b5a2e912d70fe56a8aaa68ade5d037a94912 100644 (file)
@@ -1,31 +1,27 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=20070331-051001
+PKG_VERSION:=3.2.11.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
-PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4e729f129d8f9b9abaed5121c3cd0037
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/motion
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=webcam motion sensing and logging
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
@@ -34,22 +30,19 @@ define Package/motion/conffiles
 /etc/motion.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-ffmpeg \
-               --without-jpeg-mmx \
-               --without-mysql \
-               --without-pgsql \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --without-ffmpeg \
+       --without-jpeg-mmx \
+       --without-mysql \
+       --without-pgsql \
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/motion/install  
+define Package/motion/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
        $(INSTALL_DIR) $(1)/usr/bin