[packages] motion: update to v3.2.11.1, add dependency on libpthread, cleanup
[openwrt/svn-archive/archive.git] / multimedia / motion / Makefile
index eb45d1f2ff5d11fdfd311564359632445c9b39c2..98b4b5a2e912d70fe56a8aaa68ade5d037a94912 100644 (file)
@@ -1,31 +1,27 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.9
+PKG_VERSION:=3.2.11.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
-PKG_MD5SUM:=6003011b126c9b17e23e085e7fba6536
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4e729f129d8f9b9abaed5121c3cd0037
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/motion
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=webcam motion sensing and logging
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
@@ -34,14 +30,11 @@ define Package/motion/conffiles
 /etc/motion.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-ffmpeg \
-               --without-jpeg-mmx \
-               --without-mysql \
-               --without-pgsql \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --without-ffmpeg \
+       --without-jpeg-mmx \
+       --without-mysql \
+       --without-pgsql \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \